Skip to content
VulnCrestRadar

Search vulnerabilities

Search CVE ids, WordPress plugins or keywords

Report an incidentReport
← Database

CVE-2026-73116

CVSS 4.0
10.0 critical
CISA KEV
Not listed
Technical details
Weakness
CWE-522
EPSS · 05 Nov 2026
Unavailable
Public resources
None found
Vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

No VulnCrest analysis published for this CVE yet. Below is the original CNA/NVD description, unmodified.

Description

Insufficiently Protected Credentials vulnerability in Apache Juneau. The Apache Juneau RestClient followed HTTP redirects while keeping credential headers from the original request, so a server that redirected the client to a different host or port, or from HTTPS to HTTP, could receive headers such as Authorization, Cookie, Proxy-Authorization and X-API-Key. This issue affects Apache Juneau: through 9.2.0. Users are recommended to upgrade to version 9.2.1, which fixes the issue. The fix applies to HTTP clients created by the RestClient builder; applications that supply their own HttpClient must disable automatic redirects or strip credential headers on cross-origin redirects themselves.

Exploits & detection

No public PoC or detection template found yet.

Timeline

  • Published: 05 Nov 2026
  • Last modified upstream: 05 Nov 2026

Sources & licenses

CVE / CVSS / CWE
NVD record ↗ (unmodified). This product uses the NVD API but is not endorsed or certified by the NVD. CVE® © The MITRE Corporation.
Exploitation
CISA KEV (CC0) · EPSS by FIRST.org
References used for the analysis
Analysis, summary and remediation
© VulnCrest

View JSON